January 3rd, 2012

Important Information Regarding the Latest Mac Update

While Glo will continue to support the existing Glo for Mac on Leopard (1.5.8), the latest release of Glo (1.3.1), and its licensed Powered by Glo Products, requires you to run Mac OS 10.6.0 and up (Snow Leopard or Lion).

Users with 10.5.8 (Leopard) will not be able to install this latest Release, they can however, download and Install the previous release here: Download now.

Users with 10.5.8 (Leopard) will not be prompted to accept the 1.3.1 update, they can continue to use Glo 1.2.0 normally. If you decide to upgrade your OS, Glo will also need to be upgraded.

Users with 10.6.0 and above (Snow Leopard and Lion) will be prompted to download and update to Glo v1.3.1

For more details on how to DOWNLOAD Glo, click here for instructions.

Share and Enjoy:
  • Digg
  • del.icio.us
  • Facebook
  • Mixx
  • Google Bookmarks
  • MySpace
  • Netvibes
  • NewsVine
  • Posterous
  • Propeller
  • Reddit
  • StumbleUpon
  • Technorati
  • Twitter

One Response to “Important Information Regarding the Latest Mac Update”

  1. Jackson Onyenwenu says:

    I love Glo bIble